For When You Can't Have The Real Thing
[ start | index | login ]
start > Juniper > EX4300 > NSSU Warning

NSSU Warning

Created by dave. Last edited by dave, 257 days ago. Viewed 330 times. #3
[diff] [history] [edit] [rdf]
labels
attachments
(2019-01-02)

Non-Stop Software Upgrade Is Dicey

We have attempted to upgrade a EX4300 virtual chassis pair from 14.1X53-D35.3 to 14.1X53-D47.3 using the NSSU procedure. During this procedure, we experienced a switching outage of at least 10 seconds which is unacceptable in a HA environment.

In conversations with Juniper Support they said that NSSU is only supported on firmware steps that have been explicitly tested and that the particular step we did had not been tested and is therefore not supported. They kicked me a link that had a list of version step combinations, the vast majority of which had known issues open against them.

At the same time we had attempted to bring a EX4550 VC pair from 12.something to 15.something. This also failed HA criteria, but since we were stepping across at least one major version rev perhaps this isn't entirely surprising. Especially given the fragility of the process noted above.

In our case we elected to stop all interruption-sensitive traffic prior to performing the upgrade (because we've been burned with HA NSSU-type upgrades before) so this was an inconvenience rather than the catastrophe it would have been had we just blindly trusted the documentation.

TL/DR: it probably won't work, so you should treat the upgrade as a full-outage and stop all interruption-sensitive processes prior to executing such an upgrade.

no comments | post comment
This is a collection of techical information, much of it learned the hard way. Consider it a lab book or a /info directory. I doubt much of it will be of use to anyone else.

Useful:


snipsnap.org | Copyright 2000-2002 Matthias L. Jugel and Stephan J. Schmidt