For When You Can't Have The Real Thing
[ start | index | login ]
start > Cisco > 3750X > 15.0(2)SE4 > LACP

LACP

Created by dave. Last edited by dave, 10 years and 102 days ago. Viewed 4,124 times. #2
[diff] [history] [edit] [rdf]
labels
attachments
(2013-10-01)

Problem

LACP link between a 3750X and a 3Com 4500G.

Solution:

Cisco 3750X:

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 channel-group 1 mode passive
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 channel-group 1 mode passive
!

3Com 4500G:

system-view
link-aggregation group 1 mode static
link-aggregation group 1 description Link to Cisco
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid vlan 2 tagged
 port hybrid vlan 1 untagged
 broadcast-suppression pps 3000
 undo jumboframe enable
 stp edged-port enable
 lacp enable
 port link-aggregation group 1
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid vlan 2 tagged
 port hybrid vlan 1 untagged
 broadcast-suppression pps 3000
 undo jumboframe enable
 stp edged-port enable
 lacp enable
 port link-aggregation group 1

Show the config on the Cisco:

show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

M - not in use, minimum links not met u - unsuitable for bundling w - waiting to be aggregated d - default port

Number of channel-groups in use: 1 Number of aggregators: 1

Group Port-channel Protocol Ports ------+-------------+-----------+----------------------------------------------- 1 Po1(SU) LACP Gi1/0/1(P) Gi1/0/2(P)

The 3Com complains that LACP isn't enabled on the remote partner, but the link comes up:

display link-aggregation summ

Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing Actor ID: 0x8000, 001a-c1a4-bc00

AL AL Partner ID Select Unselect Share Master ID Type Ports Ports Type Port -------------------------------------------------------------------------------- 1 S 0x8000,885a-9204-9080 2 0 Shar GigabitEthernet1/0/1

no comments | post comment
This is a collection of techical information, much of it learned the hard way. Consider it a lab book or a /info directory. I doubt much of it will be of use to anyone else.

Useful:


snipsnap.org | Copyright 2000-2002 Matthias L. Jugel and Stephan J. Schmidt